Github

Mac OSXへmatplotlib導入時メモ

OSXにmatplotlibを導入してみた、公式サイトの解説では

でいけるとの説明があったがエラー発生(下記参照)

REQUIRED DEPENDENCIES AND EXTENSIONSを参照する限りどうもFreetype入っていないため
エラーとなっている模様。
そこでbrewを導入

導入は問題なく完了、再度pipにてmatplotlibを導入しようとしてみても同様のエラー
freetypeインストールされてるのにno(認識されていない)とはどういう事かと思い調べてみると
どうもMacOSXはもう一個追加してあげないとダメな模様

pkg-config導入後に再度pipからmatplotlibインストールをためしてみると今度は成功。

途中諦めそうになったぜ・・・


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です